
LESSON 4: SCENES, ACTIONS, AND BUTTONS

OBJECTIVES

When you have finished this section, you will understand:

• why breaking a movie into scenes saves time

• the four button states

• how actions make buttons interactive

and you will have learned:

• how to insert a scene

• how to use the Scene Inspector

• how to rename a scene and how to change the order of scenes

• how to attach an action to a frame

• how to attach an action to one state of a button

• how to use the Stop and Go To commands

EXERCISES

SCENES

Scenes provide a way to divide and conquer a big project so it doesn’t get out of control. You can use

scenes to organize the movie thematically. Because each scene has its own layers and Timeline, you

work with smaller, more manageable chunks—especially important when you begin revising and making

changes. You can easily see how much time you would waste scrolling through a Timeline with a

thousand frames or more than 50 layers.

Each scene also has its own artwork, so when artwork is shared

between scenes, be sure you use symbols. Without symbols,

the artwork must be duplicated, making your final movie larger

and slower.

In this exercise you will create a scene for the beach graphic

your traced in Lesson 2.

To use scenes to organize a movie:

1. Open boat21.fla from the Lesson4 folder.

2. Choose Insert > Scene to create a new scene 
(see Figure 4-1).
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Figure 4-1

Creating a new scene.



The new scene has an empty Stage with the pale yellow background chosen for the movie, an
empty Timeline, and one empty layer. The Library is unchanged. At the top of the Timeline is 
a tab with the name of the new scene, Scene 2 (see Figure 4-2).

Figure 4-2

The new scene has an empty Timeline and one empty layer.

3. Choose the Edit Scene icon. It is in the upper right corner of your screen above the Timeline. 
It looks like the clapper boards used to signal Take 1 in making a movie.

Two scenes are listed in the Scene Edit pop-up menu: Scene 1 and Scene 2.

4. Click on Scene 1 in the Scene Edit pop-up menu to return to Scene 1 (see Figure 4-3).

Figure 4-3

Click on Scene 1 in the Scene Edit pop-up menu to return to Scene 1.

5. Drag downward on the bottom of the Timeline to expand it until you can see all six layers.

6. Click in the first frame of the Beach layer.

7. Right-click (PC) or Cmd+click (Mac) in the highlighted frame and choose Copy Frames from the
pop-up menu (or choose Edit > Copy Frames).
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8. Choose Scene 2 in the Scene Edit pop-up menu and select the first frame of Layer 1 
(see Figure 4-4). Right-click (PC) or Cmd+click (Mac) and choose Paste Frames
(or choose Edit > Paste Frames).

Figure 4-4

Select the first frame in layer 1 of Scene 2.

9. Save as boat22.flain the My Work folder. Close the file.

To clean up Scene 1:

1. Open boat22.fla from the My Work folder or the
Lesson4 folder.

2. Choose Windows > Inspectors > Scene.

The Scene Inspector opens.

3. Choose Scene 1 from the Scene Inspector and select
the Beach layer. Click on the Trash can at the bottom
of the Timeline to delete the layer (see Figure 4-5).

The Beach layer will not be needed in Scene 1.

Note: Even though the Beach layer is locked, you can

delete it.

4. Drag the bottom of the Timeline up until you see only
the five layers of the Timeline.

5. Save your file as boat23.flain the My Work folder. 
Close the file.

In the next exercise, you will rename the scenes and

change their order in the Scene Inspector. When a movie 

is divided into scenes, the scenes are played in the order 

in which they appear in the Scene Inspector.
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Figure 4-5

Clicking on the Trash button
deletes the selected layer.



To rename scenes and change their order:

1. Open boat23.fla in the My Work folder or the Lesson4 folder.

2. Choose Window > Inspectors > Scene and then highlight Scene 1.

3. Click on the Properties button. The Scene Properties dialog box opens. Type the new name of
the scene, Boat, in the Name text box and click on OK (see Figure 4-6).

The label on the tab above the layers now reads “Boat” (you might have to move the Scene
Properties dialog box to see the label).

Figure 4-6

Type Boat in the Name text box of Scene Properties.

4. In the Scene Inspector, highlight Scene 2 and click
on the Properties button. The Scene Properties
dialog box opens. Type the new name, Beach, in 
the Name text box and click on OK.

The label on the tab above the layers reads “Beach.”

5. Place the cursor over Beach in the Scene
Inspector. Hold down the mouse button and drag
Beach to the top of the list (see Figure 4-7).

Now Beach is the first scene in the movie.

You will add static frames to the Beach Timeline so the

image stays on the screen long enough to be seen.

6. Select Frame 10 of the Beach layer. Right-click
(PC) or Cmd+click (Mac) and choose Insert Frame
(or choose Frame from the Insert menu).

7. Save the file as boat24.fla in the My Work folder. 
Close the file.
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Figure 4-7

Dragging the Beach scene to the top of the list.



ACTIONS

If art and animations are where the fun is in Flash, actions are where the power is. Use actions to make

something happen when the movie reaches a certain frame or when the viewer-participant interacts

with the movie by pressing a button or typing information into a form.

Flash has provided some simple actions you can set up with a mouse click. In Flash 4, developers 

have the toolkit they need to create very sophisticated actions. Setting up sophisticated actions

requires knowledge of programming and is beyond the scope of these lessons.

In the next exercise you learn to attach an action to a frame so that the action is triggered when the

movie reaches that frame. Actions are also often attached to buttons so that rolling the cursor over 

a button or clicking on a button triggers the action.

Creating a separate layer for actions, like the Actions and Label layer in the exercise below, is a 

good idea.

In the finished movie, the movie stops playing at the end of the Beach scene. To play the Boat scene,

the viewer-participant has to click on the Duckhead button, which will be placed at the end of the

Beach scene. Right now, your movie does not stop at the end of the Beach scene, but in this exercise,

you will create an action to stop the movie. Later you will set up the Duckhead button so it launches

the next scene.

To attach an action to a frame:

1. Open boat24.fla in the My Work folder or the Lesson4 folder.

2. Choose Control > Play All Scenes. Then use Ctrl+Alt+R (PC) or Cmd+Opt+R (Mac) to rewind 
the movie and press Enter (PC) or Return (Mac) to play all the scenes in the movie.

The movie plays through, moving from the first scene (Beach) to the second scene (Boat) 
without pausing.

3. Select the Beach scene from the Scene pop-up menu.

Click on the Add a Layer icon at the bottom of the Timeline. It looks like a plus sign on a page 
of paper with a corner fold at the bottom right.

4. Double-click on the layer name and rename it Actions and Labels. Select Frame 10 of the Actions
and Labels layer. Right-click (PC) or Cmd+click (Mac) and choose Insert Keyframe (or choose
Keyframe from the Insert menu).
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5. Right-click (PC) or Cmd+click (Mac) on Frame 10 (or choose
Modify > Frame). From the Frame pop-up menu, choose Properties
(see Figure 4-8).

The Frame Properties dialog box opens.

6. Choose the Actions tab. Click on the Add (+) button to add 
an action.

A pop-up menu opens, with Action choices (see Figure 4-9).

7. Choose Stop. In the Parameter pane on the right
side of the window, Stop appears in a highlighted
bar with the words “No parameters” beneath it.
Click on OK.

Note: A parameter is an additional instruction added to

the action. For example, in the sentence “Stop three

feet in front of the stop sign,” three feet and in front of

are parameters, specifying where to stop. Some Flash

actions have parameters; the Stop action does not.

Frame 10 has an a above the 

hollow keyframe circle, indicating

that the frame contains an action

(see Figure 4-10).

Note: Actions are always inserted 

in a keyframe.

8. Choose Control > Enable Frame Actions. Rewind and play the movie.

The movie stops at the end of the Beach scene (Frame 10).

9. Save your file as boat25.flain the My Work folder. Close the folder.
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Figure 4-8

From the pop-up menu,
choose Properties.

Figure 4-9

Click on the Add (+)
button to add an action.

Figure 4-10

The a above the keyframe dot shows that the frame contains an



BUTTONS

Stopping the movie by attaching an action to a frame was easy. Now you want to add navigation to

your movie so the user can choose to advance to the next scene. You’re ready for buttons. In the

following exercise, you will make a button from an existing graphic symbol. Then you will edit the

graphic so the button looks different when you move your cursor over it, when you click on the button,

and when you release it. Later you will add an action to the button.

First you will make a copy of the Duckhead movie clip symbol and change the behavior of the symbol

from movie clip to button.

To make a button:

1. Open boat25.fla in the My Work folder or the Lesson4 folder.

The beach scene is open.

2. Click on the Add a Layer icon at the bottom of the Timeline on the left.

Double-click on the layer name to rename it Duck Button.

3. Select Frame 1 in the Duck Button layer. Choose Insert > New Symbol. Name the new symbol
Duck Buttonand choose Button as its behavior. 

The symbol-editing window opens, showing a new Timeline with one layer and one keyframe.

The Button Timeline is different from the others you have seen. It has four labels—Up, Over, Down, and

Hit—that correspond to the following four button states (see Figure 4-11).

Figure 4-11

The Button Timeline and four labels: Up, Over, Down, and Hit.

• Up: The state of the button when it is sitting on the Stage.

• Over: The state triggered by rolling over the button with your cursor.

• Down: The state triggered when you click on the button.

• Hit: Defines the area of the button that is active—in other words, the area you can click on to trigger

the action.

First, you need to import and center the duckhead.swf image.

4. Choose File > Import and import duckhead.swf from the Lesson4 folder. Choose the Arrow tool
and draw a marquee to select the graphic.

5. Choose Window > Inspectors > Object. Check Use Center Point and enter 0 for both the x and
y positions.

The graphic is centered on the crosshair in the center of the Stage.
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Only the first frame in the Button Timeline, labeled Up, has a keyframe. You need to add keyframes to

the other frames, and you need to modify the graphic so the button looks different in the various

states. You can leave the graphic as it is for the Up state. For Over, you change the color of the graphic

in the following steps. Then in the next exercise, you animate the Down state of the button with the

Shape Tween movie clip you created in Lesson 3.

First, you need to insert a keyframe in the other three frames.

6. Select the Over frame and press F6 to insert a keyframe.

A black dot appears in the Over frame, indicating that it is a keyframe and that it has content 
(the duckhead graphic).

7. Select the Down frame and press F6 to insert a keyframe. Select the Hit frame and press F6
to insert a keyframe.

Now you have four keyframes, and each one contains the Duck Button graphic.

Remember that the Hit frame is different from the others; it defines the area you can click on to trigger

the action. You define the Hit area by drawing a rectangle a little larger than the button on the Stage.

8. Select the Rectangle tool with the currently selected fill and draw a rectangle on the Stage a little
larger than the button graphic.

9. Select the Over frame and choose the Paint Bucket (U) from the Drawing toolbar. Click on the
Fill Modifier and choose a pale gray blue from the color palette.

The color in the Fill Modifier changes to the blue you chose.

10. With the duck graphic selected, choose Modify > Break Apart.

The fill is dotted and the lines are striped.

11. Now use the Paint Bucket to change the fill to blue.

This graphic is for the Over button state; when you move your
cursor over the button, you will see the outline of the duck with
a blue background (see Figure 4-12).

12. Now you can test your button. First, close the current window
by clicking on the Beach tab, by pressing Ctrl+E (PC) or
Cmd+E (Mac) or by choosing Edit > Movie.

13. Choose Control > Enable Buttons (see Figure 4-13)
and select Frame 10 from the Beach scene. Move your
cursor over the Duck button.

The button changes. The button is now an outline of
the duck’s head with a pale blue background.

14. Choose the Control menu again and deselect Enable
Buttons. Save your file as boat26.flain the My Work
folder. Close the file.

Note: When Enable Buttons is checked, you cannot select

and edit a button on the Stage.
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Figure 4-12

The changed button color and
outline for the Over state.

Figure 4-13

Choose Control > Enable Buttons
before you test your button.



CREATING AN ANIMATED BUTTON

Now that you’ve modified your button, you can use a movie clip symbol to add animation to your

button. This is a relatively simple way to add more “splash.” In this exercise, you use the Duckhead

movie clip symbol you created in Lesson 3 to animate your Duck button in its Down state.

To create an animated button:

1. Open boat26.fla from the My Work folder or the Lesson4 folder.

2. Press Ctrl+L (PC) or Cmd+L (Mac) to open the Library (or choose Window > Library).

3. Click on the Edit Symbols button at the top right of the Timeline. Click on Duck Button to edit 
the Duck Button symbol.

The symbol-editing window opens.

4. Select the Down frame. Select the duckhead graphic and delete it.

The crosshair for the symbol remains in the center of the Stage.

5. Drag the Duckhead movie clip from the Library to the Stage (see Figure 4-14).

Figure 4-14

Dragging a movie clip from the Library to the Stage.

Note: It’s essential that your movie clip be aligned precisely with

the Duck Button symbol crosshair so they will align perfectly when

the movie plays.

6. To align the two symbols, click on the crosshair of the movie
clip graphic. Use the arrow keys on the keyboard to move the
image one pixel at a time until the crosshair of the Duck Button
symbol and the crosshair of the Duckhead movie clip are lined
up (see Figure 4-15).

Note: To move 8 pixels at a time, hold the Shift key down while

pressing an arrow key in the desired direction.

7. Click on the Beach scene tab to close the symbol-editing
window and return to the Stage.
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Figure 4-15

Aligning the crosshairs of
the two symbols.



To see how the movie clip works, you must test the movie. Movie clips do not display when you play

the movie on the Stage.

8. Press Ctrl+Enter (PC) or Cmd+Return (Mac) to test the button.

Because you attached a Stop action to Frame 10, the movie stops at the end of the Beach scene.

9. a. Look at the button before you move the cursor toward it. The duck’s head is green and its body
is tan. This is the Up state.

b. Roll the cursor over the button. The duck’s head and body appear as outlines against a pale 
blue background. This is the Rollover state.

c. Click on the button and do not release it. The movie clip plays. This is the Down state. The
button doesn’t work yet because it doesn’t have an Action attached to it. You will attach the
Action in the next exercise.

d. Release the button and move the mouse away from the button. The button is once more in its 
Up state with the green and tan duck.

10. Save the file as boat27.flain the My Work folder.

ADDING A BUTTON ACTION

Of course, the real point of buttons is to add interactivity. In the next exercise, you will use the Go To

action to set up the navigation from the last frame in the Loading scene to the first frame in the Intro

scene. While the movie is preloading, your viewer might glance away or even walk away. You want

viewers to click on the Duck button to start the introduction so you know you have their attention.

To prepare for the action, you will add a label named build to Frame 1 of the Boat scene. Adding a label

is a good idea so you can use a label instead of a frame number to specify the frame you want to go to.

Using a frame label is often more reliable because revisions cause frame numbers to change. Because

the label is displayed on the Timeline, you can easily troubleshoot a Go To action that goes astray. Many

people find labels easier to remember accurately, which helps prevent careless programming errors.

After you create the label, you will set up the action on the Actions tab of the Properties dialog box. 

Go To is one of a set of actions you can “program” without knowing any code, because Flash has set

up menu options to help you build the code step by step.

Flash 4 contains a complete toolkit of actions for developers to use. More sophisticated actions

require you to know programming basics.

To add a button action:

1. Open boat27.fla in the My Work folder or the Lesson4 folder.

2. Choose the boat scene from the Scene pop-up menu above the Timeline.

You are now in the Boat scene, with the Boat Timeline displayed.

3. Click the Add Layer icon at the base of the Timeline to add a layer for your label. Double-click on
the layer name and type Actions and Labelsas the layer name.

Select Frame 1 in the Actions and Labels layer and right-click (PC) or Cmd+click (Mac). From
the pop-up menu, choose Properties.

The Frame Properties dialog box opens.
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4. Choose the Label tab and type beginin the Name text box. Choose Label as the Behavior
and then click on OK (see Figure 4-16).

Figure 4-16

The Label tab of the Frame Properties window.

A small red flag appears in Frame 1 and the word “begin” is displayed next to the Frame
(see Figure 4-17).

Figure 4-17

The Timeline, showing the label and flag.

5. Click on the Beach scene in the scene pop-up to open the Beach Scene Timeline. Select Frame
10. Click once on the Duck button on the Stage to select it. Right-click (PC) or Cmd+click (Mac) 
on the button and choose Properties from the pop-up menu (or choose Modify > Instance).

The Instance Properties dialog box opens.
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6. Choose the Actions tab and click on the plus
(+) button. From the pop-up menu, choose 
Go To (see Figure 4-18).

Flash inserts three lines of code in the Actions pane

and parameters appear in the Parameters pane 

(see Figure 4-19). The code looks like this:

On (Release): This line of code means “when the 

button is released.”

Go to and Stop (1): This line of code means “move

the current Frame Indicator to Frame 1 and Stop.”

End on: This line of code ends the action.

Figure 4-19

The Actions tab of the Instance Properties dialog box, showing three lines of code.
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Figure 4-18

The pop-up menu for choosing actions.



7. Locate Go to and Stop (1) at the top of the Actions pane. In the Parameters pane, click on the
down arrow beside the Scene selection box and choose Boat as the name of the scene to which
you want the movie to go.

In the Action pane, the second line of code changes to Go to and Stop [Boat, 1], which means
you should go to the Boat scene, frame 1.

8. In the Frame area of the Parameters pane, choose Label and choose Begin from the list of labels
(it is the only label in this scene).

The code in the Actions pane changes to Go to and Stop [Boat, “Begin”], which means you
should go to the Boat scene, to the frame labeled “begin.”

Note: The quotation marks around “begin” tell the program that the word is not a programming

command but a string (in this case, a string of letters) that you have entered. A string can also be a

series of numbers or a mixture of letters and numbers.

9. At the bottom of the Parameters pane, check the box next to Go To and Play.

The second line of code changes to Go To and Play [Boat, “Begin”] (see Figure 4-20). This is
like programming with a friend whispering the correct code in your ear—or even better, because
you can’t make a spelling error.

Figure 4-20

The Actions tab after you have made your choices.

10. Click on OK to close the dialog box and then press Ctrl+Enter (PC) or Cmd+Return (Mac).

Your movie plays the Beach scene and stops. When you click on the Duck button, the movie
navigates to the Boat scene and plays it to the end.

11. Choose Window > boat27.fla to return to the Flash file. Save your file as boat28.fla in the 
My Work folder.
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SECTION ASSIGNMENT

• Change the action of the Duck Button instance in Frame 10 of the Beach scene so that you
go to the last frame of the Boat scene when you release the button.

• Change the color of the Rollover state of the Duck button.

Note: You must have Control > Enable Buttons turned off before you can select and edit a button.
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